Hello,world;
背景
试机题
- Idea: 经典
- Data: ASFOS
- Std: 无
- 题面: ASFOS
描述
输出 Hello,world!
输入格式
无
输出格式
Hello,world!
样例
样例输入1
无输入
样例输出1
Hello,world!
汇编语言
bdos equ 0005H ; BDOS entry point
start: mvi c,9 ; BDOS function: output string
lxi d,msg$ ; address of msg
call bdos
ret ; return to CCP
msg$: db 'Hello, world!$'
end start
Fortran
PROGRAM Hello
WRITE (*,*) 'Hello, World!'
STOP
END
BASIC
PRINT "Hello, World!"
END
B(启发了现在广泛应用的C语言。)
main()
{
putstr("Hello world!*n");
return(0);
}
Pascal
begin
writeln("Hello,world!");
end.
C|C++
#include <stdio.h>
int main()
{
printf("Hello,world!");
}
C++
#include <iostream>
using namespace std;
int main(){
cout<<"Hello,world!"<<endl;
return 0;
}
C# Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace demo
{
class Program
{
static void Main(string[] args)
{
Console.WriteLine("Hello,world!");
Console.ReadLine();
}
}
}
Python2
print('Hello,world!')
Python3
print('Hello,world!')
Java
import java.io.IOException;
import java.util.Scanner;
public class Main {
public static void main(String[] args) throws IOException {
System.out.println("Hello,world!");
}
}
PHP
Hello,world!
注:PHP会把不在他的流里面的字符输出,已知最短写法。
JavaScript
print("Hello,world!");
文言(不支持)
这是不支持的语言
吾有一言。曰「「Hello,world!」」。書之。
更多语言
更多语言,详见这个搞怪的项目